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TASK # 2 

OPTIMIZATION PROBLEMS. 

TRANSPORTATION PROBLEM – APPLICATION IN WATER 

RESOURCES MANAGEMENT 
 

 

1. Initial data 

A simplified scheme of the water management system (WMS) is presented on Fig. 1.  

According to initial data provided in Terms of Reference (TOR) the WMS consists of 3 water sources 

– a pumping station (PS 1) abstracting water from a reservoir, a pumping station (PS 2) abstracting 

surface water and a pumping station (PS 3) abstracting groundwater. These water sources are named 

А1, А2 и А3. The water sources have supply capacities of the following volumes of water per day (in 

thousands m3): 1 40A
W = , 2 40A

W =  и 3 20A
W = .  

 

Fig. 1. Schematic View of the Water Sources, Delivery Networks and Water Users  

The water users are 3 Irrigation Fields (IFs), together with their Regulating Reservoirs (RRs), which 

are located at a command elevation above the IFs. Generally, the water users are named В1, В2 и В3.  

The water demand per day of these three water users are as follows: 1 30B
W = , 2 60B

W = , 3 30B
W = . 

Each water source Ai can supply water to each water user Bj.  

The costs Zi,j for water delivery from each water source Ai to each water user Bj are provided in Annex 

2 of TOR. The costs Zi,j are not constants, nor in linear relation to the volumes of water supplied from 

water source Ai to water user Bj. The functions “Costs Zi,j” versus “Supplied volumes Vi,j” are shown 

as graphs on Fig. 2. 
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Fig. 2. Water Supply Cost Functions  

The minimum cost for supplying water from 3 water sources to 3 water users has to be found, as well 

as the volumes Vi,j supplied from each water source Ai to each water user Bj have to be determined. 

 

2. Problem solution 

2.1. Type of Transportation problem 

The type of transportation problem is determined by checking if the total supply (total volumes 

available) is equal to the total demand: 

A B

i j

i j

W W
≤

≥
   

Check: 

Total supply (available volumes in water sources Ai): 40 40 20 100A

i

i

W = + + =   m3.103. 

Total demand (needed volumes by water users Bj): 30 60 30 120B

j

j

W = + + =  m3.103. 

It is evident that 
A B

i j

i j

W W<  , thus the problem is not balanced. 

The disbalance is: 100 120 20
A B

i j

i j

W W− = − = −   m3.103. (i.e. deficit is 20 m3.103.). 

A virtual water source A4 is introduced (it is called dummy water source). The virtual capacity of the 

dummy water source is 4 20A
W =  m3.103, thus the problem becomes balanced. 
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2.2. Objective Function and Constraints 

2.2.1. Objective Function 

The Objective Function (OF) is a total cost for supplying water from all water sources Ai to all water 

users Bj. The classic form of the OF is: 

Z = V11C11 +V12C12 +V13C13 +V21C21 +V22C22 + V23C23 +V31C31 + V32C32 + V33C33 + 

+ V41C41 + V42C42 + V43C43, €.         (1) 

or shortly: 
ij ij

i j

Z V C= , as i = 1 ÷ 4; j = 1 ÷ 3, 

where Vi,j are the volumes of eater supplied from water source Ai to all water user Bj; 

Ci,j – the unit costs for transporting (supplying) water from water source Ai to all water user Bj. 

Since the unit costs Ci,j for supplying water from water source Ai to all water user Bj are not constant, 

but variable in function of the volumes supplied, as it is provided by TOR, a new form of OF is 

defined: 

ij

i j

Z Z= , €,          (2) 

where Zij = VijCij is the cost for supplying water from water source Ai to all water user Bj . 

2.2.2. Constraints 

a) Supply Constraints 

These constraints take into account the capacity of water sources. 

11 12 13 1

21 22 23 2

31 32 33 3

41 42 43 4

A

A

A

A

V V V W

V V V W

V V V W

V V V W

+ + =

+ + =

+ + =

+ + =

         (3) 

b) Demand Constraints 

These constraints take into account the demand of water users. 

11 21 31 41 1

12 22 32 42 2

13 23 33 43 3

B

B

B

V V V V W

V V V V W

V V V V W

+ + + =

+ + + =

+ + + =

        (4) 

 

2.3. Creation of Solution Model in MS Excel 

2.3.1. Cost functions  

Explanations: The following text in blue and figures with Latin numbers (i, ii, iii, etc.) should not be written in the 

explanatory note. The text and figures are used to describe the procedures and to help solving the task. 

 

The graphs in Annex 2 have to be replaced and presented as equations. Thus, the equations can be used in MS Excel to 

calculate the cost for a given volume of water supplied. 
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To find equation of each function Zi,j – V one should make readings for 3 or 4 points from the graphs on Fig. 2. A table is 

made in MS Excel (see Fig. i). It is convenient to read values Zi,j for the same values of the volume V.  

  
Fig. i 

Then, using the MS Excel option Insert→Graph→ X Y Scatter graphs are inserted into the worksheet (see Fig. ii). 

       

Fig. ii 

 

The initial graph is not the desired one. The row and columns should be switched to obtain needed result (see Fig. iii). 

    

Fig. iii 
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Then, by clicking on a given function with the right mouse button and selecting the option Add Trendline from the 

context menu, a trendline is inserted (Fig. iv).  

         
Fig. iv 

In the pane Format Trendline, a Polynomial is selected and an order 3 or 4 is set. Also, option Display Equation on 

chart is selected.  

Thus, it is assumed to calculate the costs Z by the polynomial: Z = aV + bV2 + cV3 + dV4 in which the variable V is the 

supplied volume V. It is evident that all functions cross the origin of coordinate system, thus a constant (free term) of the 

polynomial function is equal to zero and may not be written. 

Then a new table, as shown on the right of the Fig. v is made. In that table all of the polynomial coefficients are written.  

 
Fig. v 

A new table is made in order to check how good is the match between the function Z calculated by means of the obtained 

equations and the function Z on Fig. 2. (see Fig. vi – the rightmost table). If the it is needed a polynomial order is decreased 

to 3 and new values of polynomial coefficients are obtained. As it is seen from the tables in the right side of Fig. vi, the 

cost values read and the cost values calculated are pretty close, thus two functions match good enough. 

 
Fig. vi. 
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The Cost functions are obtained by means of MS Excel.  

At first, for each Cost function Zi,j they are made 4 reading from graphs, shown on Fig. 2. Then chart 

is inserted in MS Excel using the data from readings. For each function Zi,j a trendline is added and 

the trendline equation is found. All the Cost functions are described as polynomes. Then a check is 

performed in order to verify the trendline equations. The results are presented on Fig. 3. 

The Cost functions for the virtual water source – Z41, Z42 и Z43, are presented as linear functions, 

which return very high costs – 15 to 20 times bigger, compared to the costs for delivery from real 

water sources to water users. 

 

Fig. 3. 

2.3.2. MS Excel model  

Two matrices are made – the Matrix of volumes and Matrix of Costs (see Fig. 4). 

         

Fig. 4. 

The Matrix of volumes. In the rows of Matrix of volumes, the number of water sources are set, and in the columns – the 

number of water users. Thus, in each cell the volume from source Ai to user Bj will be written. In the column Sum, the 

sum of the supplied volumes from source Ai is calculated. In the column Available V (cells in yellow), the capacity А

i
W  

of each water source is entered (see Fig. 4 – left picture).  

In the row Sum, the sum of the supplied volumes to water user source Bj is calculated. In the row Needed V (cells in 

yellow), the demand B

jW  of each water user is entered.  

In the Matrix of costs, in each cell it is calculated the cost for supplying water from source Ai to user Bj in dependence 

of the volume supplied from source Ai to user Bj and the Cost function for that route. As it is seen from Fig. 4 – right 

picture, the value of the volume is taken from the Matrix of volumes and the polynomial coefficients – from the left table 

on Fig. 3.  
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The column Sum contains the sum of costs for supplying water from source Ai to all users B. The row Sum contains the 

sum of costs for supplying water from all sources A to user Bj. The value in the cell F18 contains the sum of the values 

above, and the value in the cell F19 contains the sum of the values from the left. Both sums in cells F18 and F19 have to 

be the same. The value of the cell F18 (and in cell F19) is the value of Objective Function. 

An initial solution, so called basic feasible solution should be done for the volumes in the Matrix of volumes. 

One feasible solution is shown on Fig. vii.  

 

Fig. vii 

The task is solved by means of Excel Solver. This is a built-in add-on tool in MS Excel. If it is activated it can be found 

under the Data tab. If it is not activated, then go to File → Options → Add-ins. Select Solver Add-in → Manage → Solver 

→ OK. Then you can find it under Data tab, on the right side of the toolbar, in section Analyze. 

Select cell F18 and then start Solver.  

The dialog box appears (see Fig. viii). 

 

Fig. viii 

The basic feasible solution can be done using so-called 

Northwest Corner Method. 

In this method we start from the top leftmost cell. In that 

cell we write as big as possible volume, according to 

capacity or the demand for the first water source and the 

first water user. Then, we move to adjacent cell – either 

right, or down, depending which one of the constraints 

(capacity or demand) is not fulfilled.  

Thus, moving generally from Northwest corner to 

Southeast corner we allocate in each cell as big volume is 

possible. 
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It is automatically suggested by the Solver that the OF is in marked cell. In this case it is cell F18. The formula in cell F18 

calculates the value of the OF, as it is defined by equation (2).  

We look for minimum value of the Objective Function, thus we select radio button Min. 

In the box By Changing Variable Cells we point (select) the range of the volumes in the Matrix of volumes. For this 

example, this is the range from cell C4 to cell E7. when we select the range, automatically the absolute addresses of cells 

appear. 

In the box Subject to the Constraints we have to specify the constraints. They are described by the set of equations (3) 

and (4). It should be inserted, once at the time, each constraint. As it is seen from Fig. vii and Fig. viii (the first 3 

constraints) the sum of the supplied volumes to each water user Bj should be equal to its demand – these represent 

constraints in equation (4). The same is valid for the water sources (the last 4 constraints)– the sum of the supplied volumes 

from each water source Ai should be equal to its capacity – these represent constraints in equation (3).  

Since all the variables (i.e. volumes) should not be negative, we select the check box Make Unconstrained Variables Non-

Negative.  

If it is not specified or some other method is suggested, we have to select from the drop-down menu Select a Solving 

Method the option GRG Nonlinear. 

Then we click on the button Solve. 

When a feasible solution is found the notification pops up. The solution is ready and we click on Keep Solver Solution. 

CAUTION! It is advisable to try several Solver solutions, each one of them using different basic feasible solution. 

Sometimes the results preformed by Solver are not correct due to nonlinear relations. 

On Fig. ix there is an example of one initial feasible solution, and a final solution, which is declared optimal by Solver. 

However, as it is seen from Fig. 5, this is actually NOT the optimal solution. 

            

Fig. ix 

 

2.3.3. MS Excel Solver Solution  

The solution of the task is obtained by means of the Solver add-in tool of MS Excel.  

The results are presented in Fig. 5. 
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Fig. 5. Problem solution by means of MS Excel Solver 

The real minimum of the Objective function is obtained by reducing the costs for delivery from 

dummy water source to water users. In this case the costs are 20 thousand Euro.  

The real costs for water delivery are: 

Cost = 26,379 – 20,000 = 6,379 thousand Euro or 6 379 €. 

It can be seen from the table on Fig. 5, that the demand of the water users В2 and В3 is not satisfied. 

It was evident that the system has a deficit of 20 000 m3 and the most economical solution is to have 

deficits of 10 000 m3 for each of water users В2 and В3. This may not be satisfying solution for user 

B3, because the deficit represents 33% of its demand.  

 

 


